I'm also forwarding to ros-mailinglists, to make sure we don't miss any
feedback from that community ;)
On Friday 03 June 2011 00:16:17 Peter Soetens wrote: > I'd like to propose to restructure the orocos_toolchain_ros such that
> new&existing users can more easily find their way. It's mainly about
> renaming packages:
This is indeed a issue that's waiting for a proposal.
> 1. rtt_ros_integration -> rename to 'rtt_rosnode'
> -> an import("rtt_rosnode") makes your process a ros node
Looks ok to me
> 2. rtt_ros_integration_xyz_msgs -> rename to 'rtt_xyz_msgs'
> -> shorter notation, also makes it easier for users to update their
> manifest file, just prefix with 'rtt_'
Or make rtt a suffix? xyz_msgs_rtt?? And maybe even put them in a seperate stack
(We only provide typekites for the common_msgs stack)
> 3. rtt_ros_param -> rename to 'rtt_rosparam'
> -> consistent naming scheme, service is also named 'rosparam' and not
Look sane to me.
> 4. rtt_ros_service -> ?
> -> a bit confusing about what it does, I wonder if the code shouldn't
> belong in rtt_rosnode instead, since it only provides the ros.topic()
> operations, which make only sense when running in a rosnode... I would
> also propose that this global 'ros' service is available from the
> moment rtt_rosnode is imported. Today you need an extra
> 'require("ros")' in scripting and something similar in lua.
Maybe we could put the functionality of rospack, rosparam and the
rtt_ros_service, all in the rtt_rosnode package?
> What do the current users/devs think ?
If we do the renaming, we will brake a lot of existing applications, since we
are still in the experimental versioning scheme 0.x, I don't have a problem
with that but we have to communicate this name changing very clearly to our